Docker Community Forums

Share and learn in the Docker community.

Unable to run Docker

Hello All,

I’m at my wits end. Had Docker for Windows break on me, so did an uninstall / reinstall. I can’t get it to launch anymore:

In case it matters: I installed PiHole. Set u a proof of concept, on my laptop. Set my laptop to use the router as DNS, set the routers DNS to use the pihole IP. Everything worked fine. Hibernated my laptop. Turned it back on, I had no DNS. Nothing resolved. Docker was stuck at unable to connect to server or something (can’t recall). Set my computer to use a openDNS server. Logged back into docker. Docker sat at connecting. Uninstalled / reinstalled docker multiple times. I get

System.InvalidOperationException:

Failed to deploy distro docker-desktop to C:\Users\me\AppData\Local\Docker\wsl\distro: exit code: -1
(Folder is empty).

stdout: The system cannot find the file specified.
If I hit continue, it’ll load docker. I then can reset to defaults. Did that. I can then get launcher dock to show, but the docker icon in the bottom left is either red or orange.

If I paste docker run -d -p 80:80 docker/getting-started into terminal, I get:
docker: error during connect: This error may indicate that the docker daemon is not running.: Post “http://%2F%2F.%2Fpipe%2Fdocker_engine/v1.24/containers/create”: open //./pipe/docker_engine: The system cannot find the file specified.
See ‘docker run --help’.

I’ve been searching hours for solutions. Tried everything I can think of - change docker service to be a local user instead of system, run docker with / without as admin, blown away local\docker, uninstalled / reinstalled WSL, disabled / enabled hyper-v/…

Any other suggestions? WIndows 10 system.|

Thanks

Complete error:
https://www.espphotography.com/docker.txt

Crash Report F0FEC91B-75D5-419A-94ED-E2E731693449/20210614033806

Did you ever resolve this issue? I’m been working on a similar problem for a couple of days. I uninstalled Docker and installed wsl2 and reinstalled, but still the same error.