Docker Community Forums

Share and learn in the Docker community.

Unable to use Docker


(Spamhateralex) #1

Hi community,

I have installed docker quickstart terminal (Windows).
But, when I click on it to open this application, I get following problem:

Running pre-create checks...
(default) No default Boot2Docker ISO found locally, downloading the latest release...
Error with pre-create check: "Get https://api.github.com/repos/boot2docker/boot2docker/releases/latest: dial tcp xx.xx.xx.117:443: connectex: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond."
Looks like something went wrong in step ´Checking if machine default exists´... Press any key to continue...

I assume, its because of proxy…
Does anybody have a tip for me, how I can solve it? Would be very thankful!


(Spamhateralex) #2

Now I installed Docker-community-edition for windows.

When I run this command:

docker run hello-world

I get this problem:

docker: Error response from daemon: Get https://registry-1.docker.io/v2/: net/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers). See 'docker run --help'.

I already set the environment-variable like HTTP_PROXY with the value "http://1.2.3.4:3128" (just example), but it still not works.