Windows server ERROR: manifest for elasticsearch:7.11.0 not found: manifest unknown: manifest unknown

i am trying to install kibana and elasticsearch as a docker containers in a windows server operating system.

each time i run docker-compose up -d, i get an error stating the following:

Pulling elasticsearch (elasticsearch:7.11.0)...
ERROR: manifest for elasticsearch:7.11.0 not found: manifest 
unknown: manifest unknown

i don’t know if the image is not compatible with windows server or not, but i usually see the same image used in articles for windows and running successfully.

this is the image which i am using in docker-compose:

version: '3'
    image: elasticsearch:7.11.0

i am using:

  • windows server 2019
  • i have installed docker & docker compose using module packages and server manager, so i don’t have docker desktop for windows server.

i have tried the listed solution here but all uses docker desktop and i could not do the same procedure for my setup

Docker Desktop is not available for Windows Server as it is a development platform and Windows Server is supposed to be a production platform.
On Docker Desktop (Windows 10 or 11), it uses WSL2 to run a utility VM running Linux, so that’s how you can run Linux containers. On Windows Server, as mentioned, Docker Desktop is not available and Linux containers can’t run natively. You have two options on Windows Server:

  • You can run a VM on Hyper-V and install Linux on that VM. From there, you can use Docker just like you would on any Linux system.
  • You can run WSL2 on Windows Server (but that’s only supported on 2022 - not 2019). This is for development and testing purposes only, though. Also, since there’s no Docker Desktop, you have to interact with WSL2 directly. I just blogged about this: Using WSL 2 on Windows Server 2022 to run Linux containers - Microsoft Tech Community

if i am using windows server as a vm based on vmware vsphere, can i enable nested virtualization for this vm in vsphere, then proceed easily in setup?
as per this article and this one, i just need to enable nested virtualization

Yes. If nested virt is enabled you should be able to make this work.