4.14.0 Failed to Initialize

I saw the issue regarding previous versions getting the: Docker failed to initialize Docker Desktop is shutting down. With 4.14.0 the settings file has: “vpnkitCIDR”: “” and not 28.
I’ve uninstalled and reinstalled docker and I’m still getting the same issue when trying to run it.


I’m getting the same situation here

Same for me I am getting an additionnal Windows notification saying that Docker Desktop could not restart my WSL Ubuntu distro - with exit code 1

my wsl distribution works perfectly fine, It still appears as the one selected in my DD settings > Resources tab

Version: 4.14.0 (91374)
Started on: 2022/11/16 15:27:02.159
Resources: C:\Program Files\Docker\Docker\resources
OS: Windows 10 Pro
Edition: Professional
Id: 2004
Build: 19041
BuildLabName: 19041.1.amd64fre.vb_release.191206-1406

Diagnostics ID 4646E2A4-113A-459B-9A92-813C3B2E77E0/20221116154018

Same issue here, the way I’ve solved it was downloading the new update from docker Docker Desktop - Docker

After the install, docker has been update and atm everything is fine (volumes, images)

Which update? To topic title is “4.14.0 Failed to Initialize”. I don’t see any newer version.


We can’t see the diagnostics, at least most of the active users here can’t, unless they are Docker staff members.

This is a common issue which happened in multiple versions. Maybe I am lucky, because the update process worked for me most of the times. I also had an issue with the initialization of Docker Desktop (on macOS), but stopping Docker Desktop and starting it again usually helped. One time I had to restart it twice. I did not report it, because I am usually busy when I experience an issue like this, but I recently commented in some issues on GitHub. For example here


Note that this issue is about Docker for Mac and related to a previous version, so I recommend you to search for or open a new issue in the Docker for Win repository here:

Since Docker Desktop works on multiple platforms, it could be difficult to make it compatible with everything, but it seems it affects many users, so let’s hope they will find the reason eventually and fix it.

Just updated to 4.14.1 and still not working.