Docker Community Forums

Share and learn in the Docker community.

"Access denied" error when logging in to Docker Desktop for MacoS - Works on docker website

Error Message
“Access denied” when entering 2FA code in Docker Desktop for MacOS.

Error Details
When logging into Docker Desktop for MacOS, it accepts my username and password, then shows the “Two-Factor Authentication” window with one field for “Authentication Code,” when I enter the 2FA code from my authentication app, it responds with a red “Access denied.”

Additional Details
I am able to log in the Docker Hub website using the same credentials and the 2FA key generated by my authentication app.

System Details
Docker Desktop for MacOS: Version 3.5.2 (3.5.2.18)
Operating System: MacOS Catalina (10.15.7)

Any help or advice anyone could provide would be greatly appreciated.

1 Like

I am also encountering the exact same issue, except in Windows instead of MacOS

Docker Desktop for Windows 3.5.2 (WSL 2)
Windows 10 Pro (21H1 19043.1110)

I am having the exact same issue on MacOS Big Sur 11.3 and Docker Desktop for MacOS: Version 3.5.2.

Same. macOS 11.5.1, Docker Desktop 3.5.2.18

I am also facing the same issue for the past 2 weeks, MacOS: 11.5.1, Docker version: 3.5.2 (3.5.2.18)

Same. windows 10 19043 , Docker Desktop 3.6.0

Me too,
Windows 11 Beta,
docker desktop 3.6.2

Same here for Windows 10

Same here, windows 10, brand new install, 3.6.0 67351. I can login to the website with MFA with no issues.

Same here on Windows 10 19043 (21H1). The CLI login command docker login also fails with Error saving credentials: error storing credentials - err: exit status 1, out: . Logging into the web interface with 2FA works without problems.

Docker Desktop version 3.6.0 (67351).

Same in (new combination of) Docker Desktop 3.6.0 for Mac.

And 2FA on the Docker website is indeed fine as always.

Confirming I am seeing the same thing via:

  • Windows 10
  • Latest Docker Desktop (3.6.0)

I have no issue logging in via the web and 2FA.

I can confirm that I am facing this issue as well on my freshly installed Windows 10 machine.

Windows 10 Pro 21H1
Build 19043.1165
Docker Desktop 3.6.0

As with the other replies in this thread, I have no issues logging in on the website with my 2FA.

Hey everyone. I hope you are doing fine.

Same here: 2FA on Docker Hub works fine, getting ‘access denied’ when entering via Desktop app.

Running on Windows 10 Enterprise 21H1 (Build 19043.1165) with Windows Feature Experience Pack 120.2212.3530.0 + Docker Desktop
Docker version 20.10.7, build f0df350 on Powershell

I was able to fix it after realising I need to use Personal Access Token for GUI program on Windows as well instead of 2FA code. You can create it here (Docker Hub).

I hope I solved your issue.

1 Like

I had the same issue and i tried your solution but it still doesn’t work… The Personal Access Token shows error “Incorrect authentication credentials”.

Please someone should help us out, its really urgent.

Thanks

Hey there @ogelenye1 , could you please provide an exact step by step guid of what you did so that I can try and reproduce the error?

Thanks!

On the Docker Desktop App on Windows:

  1. Click on Sign In at the top
  2. Enter Docker ID and Password
  3. When I enter 2FA code it displays “Access Denied” and if i enter my Personal Access Token like you said it displays “Incorrect authentication code”.

Thanks

This works but I’m on a free account and I can only create 1 token. I use multiple devices and I need to login on all of them. Docker needs to fix this login issue asap

I was having exactly the same issue on Windows, but once I delete my access token in docker hub I was able to log in docker desktop

Same issue here on Docker for Windows with WSL2, when I login it says “Access Denied” (I have 2FA enabled).