Docker Community Forums

Share and learn in the Docker community.

Unable to uninstall Docker 1.12.1-rc1, build 7889dc7


(Mastergalen) #1

When I try to uninstall Docker from Control Panel\Programs\Programs and Features I get the prompt:

The feature you are trying to use is on a network resource that is unavailable. Click OK to try again, or enter an alternate path to a folder containing the installation package 'InstallDocker.msi' in the box below.

This is the same problem as https://forums.docker.com/t/solved-unable-to-remove-or-upgrade-from-1-12-0-rc2-beta16 but since I have a different version installed I need the download link for the InstallDocker.msi file specific to build 7889dc7.

I also tried to simply download the latest stable version and simply running that, though installation fails as it’s unable to remove the old docker version, also ends up giving the same prompt to locate the installation package InstallDocker.msi.


(Michael Friis) #2

Can you try the fixes suggested here? https://support.microsoft.com/en-us/help/17588/fix-problems-that-block-programs-from-being-installed-or-removed

I’m opening internal issue to see if there’s something wrong with out MSI


(Mastergalen) #3

Thanks for your reply. I eventually gave up and just reset Windows 10 and was finally able to install the latest version of Docker.