Docker Community Forums

Share and learn in the Docker community.

[Solved] Unable to remove or upgrade from 1.12.0-rc2-beta16


(Gravityflower) #1

Expected behavior

On running the upgrade process, the current Docker version should be upgraded.

Actual behavior

After clicking on “Update now” and after downloading the package, a window pops up stating:

“The feature you are trying to use is on a network resource that is unavailable. Click OK to try again, or enter an alternate path to a folder containing the installation package ‘InstallDocker.msi’ in the box below.”

I’ve already downloaded the InstallDocker.msi and it is in the folder. On Selecting the file, another window pops up stating:

“The file is not a valid installation package for the product Docker. Try to find the installation package ‘InstallDocker.msi’ in a folder from which you can install Docker”.

The Docker installer is in my Downloads folder. I assume it wants the specific installer for the version 1.12.0-rc2-beta 16 (build 4760), which is currently installed. But i don’t have this one anymore and i can’t find a download location where the installers are stored, annotated with version number.

Even downloading the separate InstallDocker.msi from the homepage and trying to install restults in the same behaviour.

Information

  • UPLOAD DIAGNOSTIC ID: DE80B59E-F399-4944-BEEC-898562C0ABEE/2016-07-10_11-46-59
  • Windows 10 Pro (Version 10.0.10586 Build 10586), Upgrade from Windows 8

Steps to reproduce the behavior

  1. Install DockerForWindows 1.12.0-rc2-beta 16 (build 4760)
  2. Try to upgrade

(Kppqju77) #2

OK, found the “good” installation file:
https://download.docker.com/win/beta/1.12.0.4760/InstallDocker.msi

Rename it as it asks and enjoy docker updated.

I think that for me it was AVAST that has actually removed the file…


[Solved]Cannot update/remove rc2-beta16 (Build 4760) missing .msi "The old version of Docker cannot be removed"
(Gravityflower) #3

Sorry for the late answer. I am currently downloading the msi and will try the installer. I will get back to you. I am also using Avast. I dopped them a message.

Thanks.


(Gravityflower) #4

Thanks for the link. I was finally able to update Docker. I also disabled Avast for the duration of the download and the installation since it flagged the installer on first download attempt.


(Homj) #5

I’m having the same problem over here (Avast was running, too), but the solution doesn’t work for me.
I’m really new to docker, so I’d appreciate any help, as I’m not even able to simply uninstall docker.

My version is: 1.12.0-rc2, build 906eacd, experimental


(Matthew Parsons) #6

Thank you, I had the same problem, but just couldn’t figure out the URL syntax. (I still had to rename it, “tmpB72E.msi” in my case.) Worth noting that I have Avast Free running as well - though I didn’t have to disable it once I had the proper .MSI)


(Kppqju77) #7

Do you have a build version without letters (only digits)?

If yes you can try to change the last digits in the download link…


(Mastergalen) #9

What’s the download link for InstallDocker.msi for 1.12.1-rc1, build 7889dc7 ?


(Gravityflower) #10

I honestly can’t tell you that. I use Docker for Windows currently more often, but i stopped following the topic after (as the thread states) the problem was solved for me, thanks to the help of kppqju77. If you follow the schema provided by kppqju77 you should go to the “About Docker” dialog your current installation and should find there your currently installed version, i.e. in my case Version 1.12.0-stable (build: 5968). Therefore you should try (based on my example) https://download.docker.com/win/stable/1.12.0.5968/InstallDocker.msi. Naturally you must adapt the download link to your required version.


(Mastergalen) #11

Unfortunately, I can’t open up the “About Docker” dialog because it crashes when during initialisation :frowning:

So I’m only able to get the installed version from the command line, which does not tell me the build number:

$ docker -v
Docker version 1.12.1-rc1, build 7889dc7, experimental

(Gravityflower) #12

Try to check the log file at C:\Users&lt;Username>\AppData\Local\Docker\log-<Date>_<Time>.txt.
Maybe you can find a line like the following:

[23:30:24.004][Updater ][Info ] Local build 5968 is as good as the remote 5968 on channel Stable

Also i would suggest to bring this issue (the exception and the missing links to the separate versions) up on the github repo, as the log suggests:

You can send feedback, including this log file, at https://github.com/docker/for-win/issues


(Mastergalen) #13

I found the build number in the logs, thanks.

[12:10:32.194][Program        ][Info   ] Version: 1.12.1-rc1-beta23
[12:10:32.202][Program        ][Info   ] Starting on: 9/11/2016 12:10:32 PM
[12:10:32.284][Program        ][Info   ] Resources: C:\Program Files\Docker\Docker\Resources
[12:10:32.358][Program        ][Info   ] OS: Windows 10 Pro
[12:10:32.386][Program        ][Info   ] Edition: Professional
[12:10:32.433][Program        ][Info   ] Id: 1607
[12:10:32.531][Program        ][Info   ] Build: 14393
[12:10:32.582][Program        ][Info   ] BuildLabName: 14393.103.amd64fre.rs1_release_inmarket.160819-1924
[12:10:32.586][Program        ][Info   ] Sha1: 

Unfortunately I guess the download link has a different format? None of the links below work.:

https://download.docker.com/win/beta/1.12.1.14393/InstallDocker.msi
https://download.docker.com/win/stable/1.12.1.14393/InstallDocker.msi

I’ve created an issue on GitHub here: https://github.com/docker/for-win/issues/75


(Gravityflower) #14

Unfortunately this is the windows build version, not the docker build
version. Check if you find a line as i have mentioned “Local Build …”.


(Mastergalen) #15

Nope, did a search inside all log files and it only mentions 14393 as a build number.

Otherwise, I might just write a script to check all possible build numbers from 0 to 20,000…


(Mastergalen) #16

I found valid download links with builds

  • 6433
  • 6563
  • 6833

between 0 and 20,000.

None of the downloaded InstallDocker.msi files work for the uninstallation though :confused:


(Gravityflower) #17

Go to your Docker folder (usually C:\Program Files\Docker\Docker).
Find the file with the name Docker.Backend.dll and open the file properties.
Go to Tab Details and look for the file version property. This should
be your current Docker version and therefore the version you should
try to download.


(Mastergalen) #18

Thank you, the build number is 6433 and I’ve downloaded the file.

However, after downloading the file and trying the uninstall again, it is still complaining that it is not a valid installation package.

I just noticed that inside the version column of the “Programs and Features” window it says that the version is 2.0.55718


(Gravityflower) #19

This is all the knowledge i have to offer on this matter. You should try to
contact the team for windows docker on github or open an issue there as
suggested.


(Mastergalen) #20

Alright, thanks for your help :slight_smile:


(Gravityflower) #21

Maybe one last advice (if you didn’t do that already; could be useful for
debugging the service error or providing more info to the docker team):
Since the service fails, open your event log, restart docker and see for
any failures in the summary overview within the last hour. I assume that
there should be entries with source “.NET Runtime”, since it seems to be a
.Net app. Maybe there are more information why your docker fails.