Docker Desktop M1 MacBook Pro - Sign In not working in any browser

When I try to sign in from Docker Desktop, the browser page opens in system’s default browser but clicking the “Proceed to Docker Desktop” button has no effect. It’s not working in any browser (Chrome, Safari, Firefox). Safari and Firefox console shows “[bugsnag] Breadcrumb not attached due to onBreadcrumb callback” while Chrome’s console shows “Launched external handler for 'docker-desktop://auth0/complete-login?code=RfLI8…”

MacBook Pro M1 Pro
macOS Sonoma 14.2.1 (23C71)

Docker Desktop 4.27.1 (but it hasn’t worked since a few versions prior)

Tried with

  • Chrome 121.0.6167.139 (Official Build) (arm64)
  • Safari 17.2.1 (19617.1.17.11.12)
  • Firefox 122.0 (64-bit)

Maybe macOS introduced security measures but I get no system prompts or warnings.

Seems related

But I couldn’t reproduce it.

Hi, the other post, you are referring to, made me test it in Safari and Firefox but unfortunately it doesn’t seem to be browser related because it doesn’t work in any of my browsers. I wonder if macOS prevents these “special” links (docker-desktop://) but I can confirm, that at least “magnet:” works. Also, in Firefox I had to confirm if it is ok to open the link and although I confirmed, it didn’t work. In the past, this definitely worked. So far, I don’t rely on being logged in but I guess an option to directly log in inside the app would be the best :slightly_smiling_face:

I just found something out: when I click on the Docker Desktop icon in my menu bar, it shows my user name, meaning that I am in fact logged in but when I open the dashboard it still shows the “Sign in” button in the upper right corner. So maybe, the interface just doesn’t refresh? :thinking:

That is possible, but you mean not even after restarting Docker Desktop?

I remember some years ago I noticed the main screen of the dashboard appeared for a moment even when it was officially removed. So it was just hidden and the UI (probably javascript) was slaw and it could appear for a moment. Then later some menu items didn’t appear like “Extensions” and I had to restart Docker Desktop sometimes. If you experience similar issues,I can recommend reporting it on GitHub

I just tested it with a restart and also with quit and reopen - both keep the “Sign in” button (while being signed in).
The restart actually produced some other weird thing. When I restart, the content of the overviews (container, images,…) “flash” in an interval of like a second I would say… very strange. When I quit and reopen, the flashing is gone - but the button is still there. Well, it’s strange but certainly not a serious issue.