Docker Desktop won't work on Windows 10 Home

Hey everyone,

I just installed Docker Desktop for the first time and I don’t know what’s happening. It doesn’t seem to be running. I don’t see the whale icon, and clicking on the Docker Desktop shortcut seems to do anything. I checked the task manager and see that there’s a Docker.service process running.

I think I’ve installed everything and executed every command recommended on the official page :

  • Enabled WSL 2 and installed a Ubuntu 18.04 as shown here
  • Checked Virtualization is enabled in the task manager
  • Installed Docker Desktop with it’s installer and both checkboxes checked (But the desktop shortcut hasn’t been created)

I have Windows Home 20H2. Is there a problem with the version?

Docker requires virtualization in order to be able to work. In simple terms that means that you need Windows 10 Pro at a minimum. I wish I had a better answer for you.

Then I don’t know why there is a tutorial for w10 home lol. Anyways, I ended up installing Ubuntu in a VM on VirtualBox to try docker, although I think the point of using docker is not having to use virtual machines, but this way I’ll only use one hahah.

Thanks for the answer!

I think the point of using docker is not having to use virtual machines

That is the point if you are on Linux. But Docker containers share the Linux kernel so they don’t run natively on Windows or macOS. Docker Desktop secretly runs a Linux VM under the covers and makes it look like its running natively on Windows but it is not. There is actually a VM that gets started when you start Docker.

I ended up installing Ubuntu in a VM on VirtualBox to try docker

If you want tp make your VirtualBox experience even better, try adding Vagrant. Vagrant will orchestrate the provisioning of the VM for you. It does this with a file called Vagrantfile. Here is a simple Vagrantfile that will provision and Ubuntu 20.04 VM and install docker and docker-compose automatically.

# -*- mode: ruby -*-
# vi: set ft=ruby :

Vagrant.configure("2") do |config| = "bento/ubuntu-20.04" :private_network, ip: ""
  # Provision memory and cpus
  config.vm.provider :virtualbox do |vb|
    vb.memory = "2048"
    vb.cpus = 2

  # Provision Docker and Docker-Compose
  config.vm.provision :docker
  config.vm.provision :docker_compose

Once you install Vagrant and create this file, you can start the VM and enter it with:

vagrant up --provider virtualbox
vagrant ssh

You can then use docker from within this VM. The cool part is that it maps a folder called /vagrant to the current folder on your computer. So all of your files from your PC are available inside the virtual machine under /vagrant.

You can end your session with:

vagrant halt

You can delete the VM with:

vagrant destroy

This is a great way for all developers on a team to have a consistent environment with docker regardless if they use macOS, Windows, or Linux.

I think the need for Windows Pro has changed in recent build.

Has virtualization been enabled in your bios?

Do you have a newer version of Windows installed?

Do you have WSL2 enabled with applicable distribution present?