Docker is showing Some WSL system related access rights are not set correctly problem continuously

I’m getting this error again and again whenever I try to run Docker. Please help me solve this issue. I’ve tried uninstall/reinstall wsl and docker but it didn’t work. The error message is shown bellow.

I am not sure that this is the problem, but using spaces in folder names is usually not a good idea. I know, this is 2022 with special characters and everything, but it can still cause problems. I know, Windows has spaces in folders too. Since I had many problems before because of using my full name on Windows, I don’t do it recently.

Can you run any WSL distribution?
Have you checked if the mentioned folder in the error message is there?
Is your Windows user is an Administrator? (It is the folder of your user, so it shouldn’t be a problem)

There is no space in the folder name. It’s the username of the PC. I’ve checked that folder and nothing was there. I can’t run WSL distribution, it gives some unexpected error. It’s saying that some WSL system-related access rights are not set correctly. Could it be a problem with any administrator access rights or something? My Windows user is an administrator, and I also tried running Docker as Administrator.

C:\Users\Elius H Himel\ contains spaces. When it is not handled properly in a software, it can be a problem. I am not saying it is, but it can be. If you can’t run WSL, make sure you have all the requirements like the Vitualization platform feature enabled in Windows.

WSL2 would not require Administrator privileges.

I am gonna chime in on this as it just happened to me on windows 10.

I think the issue has to do with unregistering all distros in wsl.
When you try to reinstall docker desktop after unregistering all other distros + uninstall docker desktop, you will get this message. Now, the thing is, you will also get this message if you try to install ubuntu in windows store for example.

That means the issue is with wsl itself.
After much frustration, what I did was disable WSL in Apps and Features from Windows (10) and rebooted.

I then tried to install in a terminal ubuntu : wsl --install ubuntu
This was with WSL disabled in windows features.
But this time the installation went through. Seeing that, I reopened docker desktop and sure enough, the program managed to create docker-data and docker-desktop-data in wsl.

My guess is, if you unregister all your existing distros, wsl2 is not happy. Disabling WSL in app and features (windows) and then installing a distro restart things properly I guess.

This was … frustrating to find a solution for.

1 Like