Docker Community Forums

Share and learn in the Docker community.

Docker on Mac: enabled experimental virtualization feature; now everything is hosed

I’m setting up a refurbished Mac laptop (2017 MacBook Pro 15"; 3.1 GHz quad-core i7) and when I installed Docker Desktop 3.3.1, I boldly tried ticking the “enable experimental features” checkbox which is supposed to offer an alternate Big Sur virtualization platform.

However, once I selected this and restarted Docker, it would not come back up. The whale icon in the toolbar perpetually displays the “loading” animation, and I can’t open the GUI at all.

I tried to remove Docker from Applications after quitting it from Activity Manager, but even after a reboot I can’t “because it’s open”.

I finally discovered /Applications/Docker.app/Contents/MacOS/Docker --uninstall but this fails too; it also displays an error message in the terminal when it fails:

2021-04-20 11:42:34.460 Docker[4178:32669] +[NSXPCSharedListener endpointForReply:withListenerName:]: an error occurred while attempting to obtain endpoint for listener 'ClientCallsAuxiliary': Connection interrupted

I get a dialog box which offers to reset everything to factory defaults, but clearly it doesn’t, because I’m still stuck in a situation where I can’t run Docker and can’t uninstall it either.

I don’t particularly expect a solution here (though I would be most grateful for any suggestions), but I thought I’d post this to warn against trying out this feature in its current form.

In the end, sudo rm -rf /Applications/Docker.app allowed me to remove it and start over.

Spoke too soon; I got the GUI back but it’s still spinning forever.

With the GUI back, I was able to click the bug icon and Clean / Purge Data and Reset to Factory Defaults. Now I’m back in the game. Hope this can be useful to someone who ends up in the same situation.