Docker Something went wrong with M1 Mac air

I tried to build my app and the docker was crashing in my Mac air having M1 chip. After sometime I got “Something went wrong” window which does not have option to close. I tried all methods to close Docker but it not closing nor I’m able to make a fresh instillation of Docker. When i restarted the machine this windows come back and Docker automatically starts and there is no option to stop Docker from running.

That sounds quite frustrating. My guess is that the window has a close or okay buttun at the bottom, which is not visible. If that is the case, you could try to enable a feature on Mac that allows you to drag a window anywhere so you can move it up until the button becomes visible and clickable, but it looks like it is not possible to move the top of the window out of the screen so it wouldn’t help unless you have a second external screen arranged above the builtin screen to move the window there so you can see the bottom of the window . Or maybe pressing enter while that window is in focus?

You could also forse stop Docker Desktop. Click on the apple icon in the top left corner and choose “Force quit”, click on “Docker Desktop” in the “Force Quit Applications” window.

If you need to reinstall Docker, and you don’t have any data in the VM of Docker Desktop you want to keep, you can watch my video about reinstalling Docker Desktop on Mac:

I don’t recognize the error message, but you could also try to report the issue on GitHub