Docker Community Forums

Share and learn in the Docker community.

Docker Toolbox on Windows 10, is it possible?


(Interact) #1

Hi everybody,

I just found out about the awesome Docker Toolbox installer and was about to install it on my Windows 10 laptop. But then I read here: Your machine must be running Windows 7.1, 8/8.1 or newer to run Docker Toolbox. Windows 10 is not supported.

Is there any beta/preview build available that runs on Windows 10?
Is there any Windows 10 support scheduled for Docker Toolbox?

Many thanks!
Bas


(Sven Dowideit) #2

I have it running on windows 10

you need to install a pre-release build of virtualbox from https://www.virtualbox.org/wiki/Testbuilds though.


(Interact) #3

Thanks for your reply! Unfortunately I couldn’t make it work.
I installed VirtualBox-5.0.1-102010-Win.exe and then I installed DockerToolbox-1.8.1b.exe with VirtualBox and MySys Git unchecked.

Then I started VirtualBox and I tried to create a new Docker host:

C:\Development\DockerToolbox>docker-machine.exe create --driver virtualbox dev
Creating VirtualBox VM...
Creating SSH key...
Starting VirtualBox VM...
Error creating machine: exit status 1
You will want to check the provider to make sure the machine and associated resources were properly removed.

While doing this 2 alerts showed up saying that a network interface could not be created, because an interface with the same name already existed.

Do you have any idea how to work around this?

Many thanks!
Bas


(Nathan Le Claire) #4

Thanks for the report Bas and thanks for fielding the issue Sven.

Bas, do you have any existing network interfaces in Virtualbox (you can see them in the Virtualbox GUI – Preferences => Network => Host Only Networks)? If you can delete them (i.e. no other machines are using them), please do so and let us know if that allows the create to succeed.

If that does not work out, please post the output of docker-machine.exe -D create --driver virtualbox dev into a Github Gist and paste the link here for us to take a look at the output.

Thanks for your patience and for reporting the issue.

Nathan


(Interact) #5

Hi Nathan,

Thanks for your suggestions.
I removed all network interfaces and existing images from Vbox and tried again. Unfortunately the same error occurred.

I pasted my CLI output here: https://gist.github.com/bascan/1d3ac2bcaad1a3d7dbb0
Is there anything else that I could try?

Many thanks for your help!

Best regards,
Bas


(Bpassanisi) #6

I’d like to say that I’m a Windows 7 user and am seeing the same errors that is seen in the Windows 10 output referenced earlier. I’m not sure if this is just a Windows 10 issue. This error message is in common with my output:

STDERR: VBoxManage.exe: error: Code E_INVALIDARG (0x80070057) - One or more arguments are invalid (extended info not available)
VBoxManage.exe: error: Context: “RemoveRedirect(Bstr(ValueUnion.psz).raw())” at line 1766 of file VBoxManageModifyVM.cpp


(Interact) #7

Any updates on this issue?
Anything else that I could try?

Thanks,
Bas


(Michael Chiang) #8

Wanted to update everyone on this issue.

Toolbox does support Windows 10.

However, it uses Virtualbox and Oracle does acknowledge they may have issues with Windows 10. They will close this once most of the issues get fixed. https://forums.virtualbox.org/viewtopic.php?f=6&t=68590

Hope this help!