Docker Community Forums

Share and learn in the Docker community.

Docker Windows 10 virtualization not detected

I am still new in Docker. I’ve followed the instructions from https://docs.docker.com/toolbox/toolbox_install_windows/

I already enabled the virtualization, but when I open Docker Quickstart Terminal it gives me an error.


I also did “bcdedit /set hypervisorlaunchtype off” and disabled Core Isolation but it still gives the same error message.

Already tried to download the Docker Desktop and it gives me the same error message with Docker Toolbox.

The error message tells to check the BIOS settings. Did you do that?
Another question: Are you on Windows 10 Home? If not, please use Docker Desktop.

Yes, I already turn on the virtualization in BIOS settings.

I am on windows 10 edu. Docker Desktop also gives the same error message, that it can’t detect my virtualization.

Windows 10 Edu supports virtualization. So quite sure it has to do with your hardware. The important is that you have activated VT-x and nothing else. I would uninstall everything related to Docker, then try to activate Hyper-V as Windows feature, if this works install Docker Desktop again.
From time to time I’ve already seen users complaining about not being able to use virtualization with laptops of certain manufacturers.

I also came across this problem.
Look carefully. I often find in the BIOS settings another option to enable virtualization in another section.