Docker Community Forums

Share and learn in the Docker community.

Error with pre-create check: "This computer doesn't have VT-X/AMD-v enabled. Enabling it in the BIOS is mandatory" even though it's enabled!

Running docker toolbox ( v19.03.1) from Windows 10 Home edition yields the following error message:

Running pre-create checks...
Error with pre-create check: "This computer doesn't have VT-X/AMD-v enabled. Enabling it in the BIOS is mandatory"
Looks like something went wrong in step ´Checking if machine default exists´... Press any key to continue...

I tried a lot of help threads online, but all of them boils down to enabling AMD-V (or intel equivalent) in the BIOS (done), disabling Hyper-V (can’t, Home edition doesn’t even have it), disabling hypervisorlaunchtype (done) or disabling core isolation (it’s off) and it still doesn’t work. Here are some screenshots to show some of my settings.

(All images merged into 1, because new users can’t post more than 1 image)

Running a Ryzen 3600 with x570 board, I enabled virtualization in the BIOS:
Here is my bcdedit, hypervisorlaunchtype is Off.
Windows features: I tried all permutation of turning on and off virtual machine platform / windows hypervisor platform, none of them worked, this is the current state:
Core isolation off:

I also tried disabling anti-virus, it didn’t help. Tried reinstalling docker toolbox, VirtualBox, together, separately, didn’t work. (tried VirtualBox versions 5.2.20 (included in docker toolbox installer) and the newest 6.0.10 version)

Update: I installed Ubuntu 18 (64 bit) successfully in VirtualBox, so the issue must be with Docker, VirtualBox works just fine.

Any help is greatly appreciated!


I have the same problem.

Windows 7 x64
AMD Phenom II x4 965

Virtualization activated in BIOS, VMWare and any other virtualization software works fine,
but Docker Quickstart Terminal states that “This computer doesn’t have VT-X/AMD-v enabled.”.

I just can’t get docker to run on my system :confused:
Didn’t thought it would be such a hassle, if vagrant (for example) works without a problem.

I running on Ryzen 3600 with Windows 10 pro.
already enable virtualization in UEFI .

Can run normally in Nox (Android Emulator), Virtual Box.
But cannot run DockerToolbox with the same error message as you.

I can run Docker Desktop but it seem to be conflicted with Nox, VirtualBox because I have to enable Hyper-V in Windows Features but Nox, Virtualbox need to disable Hyper-V in Windows Feature.

Anyone can solve this problem? pleas help me.

Open PowerShell as Administrator then type following command:

docker-machine create default --virtualbox-no-vtx-check

after wait for a while I can start docker toolbox normally.



it work thank you so much <3