Getting to Docker EE (Docker DataCenter) on Azure

I’ve deployed a new Docker EE cluster using the azure template, but I’m not clear how to get to the Docker Datacenter website for my new deployment. I see that a load balancer has been setup for port 443 but it doesn’t resolve when I try to get to it by it’s public IP address. Is their documentation on how to do this?

@bmccleave Are you using the URL reported in the UCPLOGINURL Output element of the template deployment?

@ddebroy We have the same issue here. The Azure templates deploys successuflly, but when we use the UCP login URL from the deployement page (output variable), we cannot connect and always get a TIMEOUT error.

Kevin, Bruce,

The deployment status is bit misleading. The status gets updated as soon as the resources for swarm are configured. It takes about 15 mins for UCP and DTR to come up once the swarm is deployed. Please try the UCP login URL again, you should be able to login. Thanks!

Hi @ushetty, it’s been more than an hour now, and we’re still now able to access the UCPLOGINURL. Everything seems to be working in Azure, but the URL doesn’t respond at all.

For the record, I just spawn the same on Amazon, and everything works. We’d prefer to use Azure though if it works.


Do you’ve few mins later this afternoon around 3:30 p.m? I can certainly look into it.

I could do right now if you’d like, does that work for you?

It’s 4:30 EST here, and I’ll leave within the next hour.

lets do at 2 p.m. I’ve a meeting starting in few mins.

Sure, what’s the best way to reach you? You’re PST right?

Thanks to @ushetty and @kevinmooreqc for looking into this further. In case others run into the same, please keep a couple of things in mind:

  1. Azure reporting a status of Success for deployment does not indicate everything is up from a Docker4Azure swarm perspective behind the scenes. It just indicates Azure is done deploying the cloud resources successfully. So you may need to wait a few minutes right after Azure reports successful deployment before the UCP URL can be reached.

  2. Go over the docker logs for init (docker logs $(docker ps -a | grep init | cut -d' ' -f 1)) and make sure there are no instances of msrest.exceptions.AuthenticationError: , UnauthorizedClientError: (unauthorized_client) AADSTS70001 . That is an indication of the fact that something is wrong with the Service Principal. Please review the steps to generate it at

I didn’t see the UPCLOGINURL as an option when I setup the swarm. I’ve already removed it and manually created the swarm I needed. I will try to set up a new swarm next week and see if I can find the setting.

It’s in the Outputs section under the Deployment blade of the Resource Group along with SSH TARGETS

I blogged about few common issues and how to make sure you setup the service principal permissions correctly: