Docker Community Forums

Share and learn in the Docker community.

How to allow pull from private registry


(jim-test) #1

I can’t seem to pull from my V1 private registry.

Error response from daemon: Get https://172.23.43.250:5000/v1/_ping: EOF

On my Linux clients I have to edit my DOCKER_OPTS for them to connect. Is there an equiv for my Windows machine?


(Anoop) #2

What did you change for DOCKER_OPTS on linux to make it work? Was it to add --insecure-registry? If so, the same should work from a windows client.


(Michael Friis) #3

@jblevins We’re working on extending settings management to be passed to the Docker engine - stay tuned.


(jim-test) #4

Has there been any progress in this area yet? Not being able to pull from my private registry renders this whole Docker on Windows thing worthless for me.


(Fresnizky) #5

I really enjoyed testing the beta, but now I’m working on a project using private registries and won’t be able to continue until this is fixed.
It’s really a shame because the performance using Hyper-V is so much better than VirtualBox.


(Afischer211) #6

Can you give some more details to the performance-improvements of hyper-v? I think also about returning to the virtualbox-based solution.


(Fresnizky) #7

I don’t have a benchmark, but the beta starter much quicker than the Virtualbox VM, and it consumes less resources even when no containers are running.


(Afischer211) #8

With the new Beta14 you can define private registries. So we can hopefully swap over to DfW instead of docker-toolbox…


(jim-test) #9

What is the correct syntax for the insecure-registries for Windows 10. I added “insecure-registries”: [“dockreg:5000”] to my config and it restarts just fine but when I try and do a docker pull dockreg:5000/mycontainer it is still trying to contact my registry host via https and not http.