Docker Community Forums

Share and learn in the Docker community.

Installed Ubuntu distribution not detected by Docker Desktop for Windows WSL 2 Tech Preview

Hi –

I’m experimenting with the Docker Desktop for Windows WSL 2 Tech Preview (as it’s described here and here). I think I covered all of the prerequisites in the latter link before installing Docker Desktop.

If I run “wsl -l -v” in PowerShell, it correctly lists my Ubuntu 18.04 distribution running under WSL 2. But when I launch the WSL 2 Tech Preview from the Docker system tray icon, I get a message saying “It seems that no distribution has been installed. Install Ubuntu 18.04 from the store.” The screenshot below shows what I’m seeing. Has anyone else run into this. Obviously this is all preview software, so it’s not a huge deal that I can’t make it work. I think the next thing I’ll try is reinstalling Docker Desktop.

Thanks for any thoughts/ideas.

Bill

I have the same problem, anyone?

me either… please anyone??

I solved the issue by setting default distro with command wsl -s <distro name>
after chosen my default distro and when i restarted docker desktop then I could see it working well

for example )
run power shell terminal and type in
C:\Users\username> wsl -s ubuntu-18.04

then right click docker desktop icon and restart docker desktop
image

I’m having the same issue. I’ve tried what bkh751 suggested and uninstalling/reinstalling Docker. A wsl option doesn’t even show up when I run docker context ls. Thanks for any tips.