"Last refresh: Never" and the spinning cursor does not stop

My OS is Windows 10 22H2, build 19045.2075. Docker Desktop is v4.12.0.

My current problem is that Docker Desktop, at the top of the Images, for Last refresh: Never the spinning cursor does not stop spinning. I ran com.docker.diagnose.exe and got the failure vpnkit.exe is not running. There is also the warning unable to fetch http://docker.com. But obviously my system can access docker.com.

Here is some background. For months I was having problems with WSL. I installed a couple more Ubuntus. Finally after becoming frustrated with WSL and Docker I dug deep enough to discover that my WSL was WSL 1. So I removed all of them (not the two for Docker) and reinstalled WSL and now I have a WSL 2 Ubuntu. But then Docker Desktop was acting up. I switched from Linux containers to Windows containers and Docker Desktop hung. It then hung whenever I tried to start it. I uninstalled Docker Desktop then did a system shutdown and re-installed Docker Desktop. That got me to the situation described above.