Docker Community Forums

Share and learn in the Docker community.

New Safari in Yosemite issue


(Cooper) #1

When I open Docker and try to click the ‘Buy More’ button, I redirect to the login page. And I fill in the username and password. It redirect to the previous page. It doesn’t show me the ‘Buy More’ page. I get the same problem when I click create repository button.


(Andy Rothfusz) #2

Hi Cooper – thanks, we’re working on this. It may be related to how Safari treats the scope on cookies now.


(Cooper) #3

Got it. Thanks for your quick reply. Do you know when Docker can fix this issue?


(Andy Rothfusz) #4

I don’t have an ETA yet. The workaround is to use a different browser, sorry.


(Cooper) #5

No problem. I will switch back to Chrome.
Thanks.


(Andy Rothfusz) #7

(David Cittadini) #8

I have exactly the same problem with the new Yosemite beta (OS X 10.10.2 - 14C68k) except that it will not let me add a repository…it just goes back to the login page…which basically means I cannot do anything with the Docker.io site.


(Sven Dowideit) #9

@davidcittadini the workaround at this point is to use a different browser.


(Danalstadt) #10

Same here. Attempting to navigate to any page on the Docker Hub logs me out.


(Christian Pekeler) #11

Safari is my browser of choice. Would appreciate if this cookie issue be fixed soon. THX


(Jean Mertz) #12

Same issue here. Still not fixed it seems.


(Ken Cochrane) #13

Just to give an update on this issue. We have been working on it since it was reported to us, and we have spent more time trying to fix it then I would like to admit. Unfortunately it was really hard to duplicate in a test environment, we finally figured that out, and we thought we had a solution, since it worked in our test en. But when we rolled it out to production a couple of times last week, it didn’t work, so we had to roll back the fix.

We are getting closer, we just aren’t there yet. We hope to have this fixed real soon, and we apologize to anyone who is effected by this bug. We are actively working on it, and we will not stop until we have it fixed.


(Alexis Vincent) #14

Just adding my voice to this issue.


(Brian Morton) #15

+1 for fixing this. This is the only site that I use that I can’t use in Safari :frowning:

Would love to see a writeup of the root cause on this when y’all figure out what the problem was.


(Annette) #16

Same thing here.
Safari/Yosemite


(Santos Jiménez Linares) #17

Same problem here.
Safari/Yosemite.


(Grzegorz Dubicki) #18

+1. Please solve it.


(Pencilcheck) #19

+1. I wonder what JS framework, web application framework are you guys using? If it is rails I can probably help out. Perhaps some headers are not set correctly?


(Gregtomei) #20

+1 this is a major problem.


(Justin Morris) #21

Do you have any update on this?