Newbie configuration problems

I installed Docker and docker desktop on my Mac (Mac OS 11.6 Big Sur) and got them both running. But with problems:

  1. It says I should update to latest. When I try, it downloads successfully. But it never actually quits and restarts itself. And I have seen lots of messages while trying to do so that said, “Failed to fetch extensions”. Would this actually be a hindrance to updating itself?

  2. I selected “Keep in dock” on the docker desktop icon. I rebooted. It came back with a question mark in place of that icon, and in fact it was not clickable. The docker command in the terminal also didn’t work. I was able to start docker desktop from an icon I found in my Applications folder, and then things were working. What do I need to be doing to make this work smoothly after reboot? Is there a smooth way to start the daemon and the command-level stuff on start up without automatically starting the desktop as well?

I saw multiple similar reports recently, which is unusual to me as Docker Desktop almost alwys worked for me on Mac, but I know, not everyone is so lucky. I have never experienced the “failed to fetch extensions” error either, but I have the latest macOS. Some issues recently were solved by updating macOS to the latest version. If your hardware supports it, I recommend updating macOS. You can also report issues on GitHub: GitHub - docker/for-mac: Bug reports for Docker Desktop for Mac

The issu with the icon and the docker command indicates that something happened during the installation and configuration files (posisbly macOS system configs as well) become corrupted. Completely uninstalling Docker Desktop and reinstalling helps sometimes. I have a video about that, but which helped multiple users, although recently some users had to update macOS to finally make it work and reinstalling it on an old macOS didn’t help. Your Mac is still newer though.

The video:

May I protest? That is bad software management that begins to fail merely one OS version behind! Mac OS updates are so often disruptive that I avoid them passionately!

Of course you may :slight_smile: The decision is yours, I’m just sharing what I see on the forum recently. For bugfixes you need to report the issue on GitHub or contact Docker support.

On the other hand, Docker had a decision too. So Docker Desktop suppors the latest macOS and the two previous major versions. At least this is what you can see in the requirements section for intel-based Macs.

When you switch to the Apple Silicon chip tab, that warning disappears. I don’t know why Apple Silicon Macs would be supported differently, so I guess it is just a mistake in the documentation, but based on your Mac version I guess you have the intel based Mac.

The latest Mac is macOS 14, so the previous two releases are macOS 13 and 12. You have an older Mac. So while I understand that updating to newer major Mac versions could be difficult depending on what that Mac is used for, you might not have other option if you need the features of Docker Desktop. If you just need Docker without the additional featurs, you can try Rancher Desktop or Podman Desktop as well. The latter claims to support (or try to support) Docker Desktop extensions.