M1 Mac Docker Upgrade or New Install gives: Docker Engine stopped and Extensions: Failed to fetch extensions error

Since I do see other similar issues being reported here, there clearly is an issue with updating Mac Docker Desktop on M1 Macs.

I was previously running Docker Dessktop Mac v.4.23.0 without any issues.
Ran version Upgrade from within the app: on restarting encountered several issues:

  • Docker app shows message: Docker Engine stopped
  • notifications errors come up that Extensions: Failed to fetch extensions
  • Docker does not respond when selecting Quit Docker Desktop from the menu
  • only way to close out is to select Quit then Force Quit from Activity Monitor

I have already done a complete Uninstall, including:
rm -rf ~/Library/Group\\ Containers/group.com.docker
rm -rf ~/Library/Containers/com.docker.docker
rm -rf ~/.docker

and a Reinstall with a new download of current Version 4.25.2 (129061)
– all with the same result

1 Like

What is your macOS version? The last solved similar issues were solved by updating macOS. Sometimes to a newer major version, sometimes at least to the latest patch version. Most issues happened on macOS 12 as far as I know.

I’m having the same issue as of this morning, completely unresponsive
M2 (not M1) - MacOS Ventura 13.4

macOS 13.6 2 came out in November. I would try to install the latest updates. You could reboot your Mac too (I don’t do it normally, just let it go to sleep) before updating. I know, its not Windows :slight_smile: but it still helps sometimes if there is a process that causes the issue.

Thank you for the quick response!

I’ve upgraded to 13.6.1 (doesn’t seem to have 13.6.2) and restarted, but Docker Desktop is still stuck on “Starting the Docker Engine…” for >10 minutes. I have 16gb ram, and have plenty of free cpu and memory available, so there’s no bottleneck afaict.

Any other info I can provide to help debug?

You can look around on GitHub

Since this is something I could never reproduce, if updating doesn’t work, I can only recommend reporting the issue where the developers cans ee it. Before you open a new issue, try to search for similar issues. Based on the forum topics, I’m pretty sure there are existing issues already.

Then Wikipedia was wrong :slight_smile:

update:

It wasn’t wrong

Thanks for the reply @rimelek
Yes, I’ve got MacOS 12.1
There are other application dependency issues that mean I can’t just now upgrade to v.13 or 14

There was clearly some significant issue that was introduced after Docker v.4.23.0 that has triggered this failure.

Is there any way that we can get Docker to incorporate a warning on the incompatibilities here with certain MacOS versions? This does seem to be coming up for a good number of users and with in a sufficiently consistent manner to point to a verifiable problem.

Would it be a problem to update to the latest macOS 12? As I wrote in my first response

So you can try to update at least 12.7. I have my MacBook only since 2022, and my use case allowed me to always update the OS, so I’m not sure if updating to a newer major version (12.7) could break anything, but it is an option nevertheless.

And that was in my third post :slight_smile: which was also the last.

Here is the GitHub Issue that I posted with all of the details:
M1 Mac Docker Upgrade or New Install gives: Docker Engine stopped and Extensions: Failed to fetch extensions error · Issue #7089 · docker/for-mac · GitHub

The issue is resolved with either reverting to Docker Desktop 4.23.x
Or updating MacOS from 12.1 to 12.7.1

It is clearly confirmed by several in that issue that there is a problem with a series of Docker/MacOS version combinations.

I encourage Docker to post a notification on these issues, until it is fully resolved in future code releases. We want to be able to trust that regular updates to Docker will continue to work for us and our teams as expected.