Docker Community Forums

Share and learn in the Docker community.

No space left on device (vmdk full)


(Ttru) #1

Hello,

I just installed docker on my Windows system with VirtualBox and ran through the https://docs.docker.com/windows/step_four/
to create my own image and run it. I’ve followed all the directions and ran this command to call my notepad doc.

docker build -t docker-whale .

I noticed this step “Sending build context to Docker daemon 158.8 M”

got up to over 1 Gb and then crashed out with this error:

$ docker build -t docker-whale .
Sending build context to Docker daemon 2.048 kB
Error response from daemon: mkdir /mnt/sda1/var/lib/docker/tmp/docker-builder579
965080: no space left on device

I’m not sure how to resolve this. Df -h shows 76G available on my local system.
I can’t seem to see where all the 20 Gb allocated to my VMDK has gone. I run du and only see a little over a Gb used.

Now whenever I try to build it gives me the same error. I can see from VirtualBox that the VMDK has filled.

I reinstalled and now it’s working. I did attempt the build command from my desktop which has multiple files on it – how does Docker know to look for the Dockerfile? The second time I ran it after reinstall from it’s own folder and it worked.

Thanks for any help.