Panic: assignment to entry in nil map

When doing docker login in the command prompt / powershell, I the error posted below. Though when doing this, docker desktop gets logged in just fine.

Authenticating with existing credentials…
panic: assignment to entry in nil map

goroutine 1 [running]:*fileStore).Store(0xc0004d32c0, {{0x0, 0x0}, {0x0, 0x0}, {0x0, 0x0}, {0x0, 0x0}, {0x149b9b7, …}, …})


Although powershell is available for Linux and macOS as well, I assume you installed Docker Desktop on Windows, right?


I thing so because I have the same problem and I certainly installed on Windows… Do you have a solution? QVQ


I believe I’m experiencing the same issue - new laptop, new docker desktop for windows install. can’t login via command line:

goroutine 1 [running]:*fileStore).Store(0xc0004d4600, {{0x0, 0x0}, {0x0, 0x0}, {0x0, 0x0}, {0x0, 0x0}, {0xc00003c420, …}, …})
/go/src/ +0x49


I’m experiencing the same issue with my new windows laptop with fresh installation of docker.

Sorry, shortly after posting, I came to think about this very important info.
You are of course absolutely correct. This is on a freshly installed Windows 11, latest docker-desktop.

I could try, if wanted. To do a fresh install on a Linux box and see if I experience the same issue there?

I have the same issue, works for me when I use WT and ubuntu, but not from cmd, git bash or powershell

If it is not a problem for you, that coud help to find out if it is only a Windows issue, but since so many of you had the same issue on the same day, it is very likely to be a bug. Can you share this issue on GitHub?

I tried it on my Windows even though I don’t use Docker Desktop on Windows only when I try to help someone, and it worked for me but it doesn’t mean that it’s not a bug.

If you report the bug on GitHub and share the link here, everyone can join the conversation there too.

In the meantime everyone could try to rename the .docker folder in the \Users\USERNAME folder and try the docke rlogin command again. If the error was something in that folder, that can fix it, but even if it is the case, it shouldn’t have happened.


you cloud try to run docker logout and then docker login ,it works for me .


That’s a good idea too.

I can verify that this did help on my PC too. I have created en issue here:

Hi all, a fix for this will be tracked on the docker/cli issue tracker: Nil pointer dereference on loading the config file · Issue #4414 · docker/cli · GitHub

Thank you!

I was using “az acr login” to do an azure registry docker login and getting this error, but I followed your advice and did a “docker logout” and that cleaned up my issue.

1 Like

worked for my on my box (latest docker - Docker version 24.0.2, build cb74dfc) on W11. thx for solution.

its work for me. Recommend!

This solution works for me

“docker logout” works for me. Thank you!

Logout worked here too!