Docker Community Forums

Share and learn in the Docker community.

Pushimg image into the repository


(Anvika1) #1

I am trying to push my image into the repository it says preparing and waiting and then returns an error saying unathorised : authentication required.

But it doesn’t ask me to fill my credentials. How am I suppose to authorise it. Please help me out.


(Anoop) #2

Hi anvika1 - Can you please post the exact command you ran to push the image into the repository?

One common gotcha is forgetting to put the namespace in from of the repo name during the push. The namespace is usually a org name or a user id in DTR.

So, instead of running docker push dtr.example.com/myrepo:1.0 you would need to run docker push dtr.example.com/myorg/myrepo:1.0. Of course you need to tag the image appropriately before doing the push.


(Anvika1) #3

Yes. The command I used is docker push anvika1/image5:1.0 .
Before this i alread tagged my image with the correct repository name.


(Anoop) #4

Oh, I assumed you are using DTR. My bad.

Can you run docker login first? It will prompt you for user id, password and email. These should be as configured at hub.docker.com. Then please attempt the push again.


(Anvika1) #5

Let me try this. Thank you.


(Anvika1) #6

Looks like its working. Thank you so much. I didn’t know about the login command.

thanks again.


(Anoop) #7

Great, glad to know it worked. Thank you for the update!


(Anvika1) #8

I am writing you about a question as nobody has replied to it in the forum. I am using docker-py to remotely invoke docker to perform operations. The problem is I am using docker on windows and I am having trouble in making docker listen to a tcp port. I know the docker.conf file has to be changed. I can do that in ubuntu, but i don’t know how it works on windows. I am getting an error when I run the python script,
cli = Client(base_url=‘unix://var/run/docker.sock’). I also tried changing it to, cli = client(base_url=’-H tcp://127.0.0.1:2375 -H unix:///var/run/docker.sock’). I still get an error which says:
Traceback (most recent call last):
File “”, line 1, in
TypeError: ‘module’ object is not callable

which i think is because of not changing the TCP port. Please help me out.

Thanks in advance.


(Anoop) #9

Hi - Are you running the docker daemon on windows?


(Anvika1) #10

Yes anoop. I am stuck from a very long time. Please let me know if you can extend some help


(Anvika1) #11

This is the link to my revised question. I think this would be clear to you.