Docker Community Forums

Share and learn in the Docker community.

Unable to add payment details


(Dan) #1

I’m currently using tutum, but I’m looking to migrate my services to Docker Cloud. Unfortunately I don’t seem to be able to add cards details to my account. I’ve tried both Chrome and Firefox and neither seem to work.

There’s no error displayed in the page, but i see a failed (404) response if I monitor the network request. The failure seems to relate to this endpoint: (i’ve replaced my account name in the example below).

https://cloud.docker.com/api/billing/v3/account/MYACCOUNTNAME/billing_info/?_=1456323532634

The response contains this JSON.

detail: Object not found

Could it be related to me being in the UK?

I’m keen to get started migrating our services over, so any help on giving you some money is much appreciated.

Thanks
Dan


(Kickingthetv) #2

Thanks Dan,

We’re looking into this now!


(Kickingthetv) #3

Hi Dan,

Here’s the error: “The payment gateway declined the transaction because the security code (CVV) or expiration date did not match.”

Can you please check your credit card info is entered correctly and try again?


(Dan) #4

Hi

Thanks for the info, i’ll try it again and let you know.

Thanks
Dan


(Dan) #5

This did turn out to be related to the card I was using.

Thanks for looking into it.

Dan


(Kickingthetv) #6

Great, glad we could help.


(Yourcursus) #7

I have a similar issue. All the fields are green, but when I click the “Charge” button, nothing happen.


(Yourcursus) #8

Another thing, when I go to fill in the billing info in the Account info page,I fill in all the fields, click the “Save” button, all the fields are emptied, no message, and I guess my info aren’t kept.


(Yourcursus) #9

Ha ! I tried with Chromuim, instead of Iceweasel, and it worked !

With Iceweasel, the save button is not changing to “Loading …”, and so never show the success message.
I guess is only a browser compatibility issue.


(Borja Burgos) #10

Thanks for bringing this to our attention.


(Hnymand) #11

Hi, I just experienced the same issue on Firefox (on windows). The fields would just blank out after hitting save. Using Chrome instead solved my problem. I am now able to spend money again :slight_smile:


(Editshare) #12

Same for me on Firefox/Ubuntu. There are JavaScript errors in the web console related to getElementById() which fails. Please fix


(Cypu) #13

Hi, I’m a new Docker user and probably I have a similar problem to described above. When i try to enter to https://cloud.docker.com/ I receive error message “Uhoh Something went wrong”. I checked the problem in console and there was 404 error : “NetworkError: 404 Not Found - https://cloud.docker.com/api/billing/v3/account/username/billing_info/”.
I try to open this under Ubuntu/Firefox.
Does anybody know where might be a problem ?