Installing Docker on Windows 10 Home

I’ve used both *.bat scripts and made registry modifications: (Edition ID, Product Name) but when i run installer - i receive: Installation failed:

What is the reason?

Can somebody help please?

Thank you @hessi9 and @mapk! You’ve saved my day, everything works like a charm! Ran two scripts and changed regestry.

Thanks a lot @hessi9 and @mapk . It works like a charm.

@hessi9 and @mapk +1, it worked for me too. Emphasis on run the .bat scripts as Admin since Docker will give you a windows error if the Hyper-V packages are not added properly.

Dear Docker staff, please simply support Win 10 Home? This seems like a pointless play on Win 10 configuration chess.

I signed up just to say that the method @mapk described using @hessi9’s script worked perfectly for me.
I don’t remember if I ran both of the scripts and I’m not sure how to check it (I don’t see anything like Containers on Windows Features), and I believe I changed only the ProductName variable on the registry, but don’t quote me on that either. Also, I didn’t have to revert this change, apparently restarting Windows to apply updates changed it back.
Anyway, thank you very much top both of you!

See my notes here about what worked for me: Installing Docker on Windows 10 Home.

The installation worked for me following @mapk and @hessi9 's instructions. Also, aruku64 I had the same issue, restarting after editing the registry reverts the changes. So you were correct, you need to edit the registry and then start the installation.

My steps:

  1. To install HyperV on Windows Home I used @hessi9 bat commands
  2. To install Docker on Windows Home without having to install a 3rd party product I used @mapk tip (change registry instead of editing installer).

Additional Info: It was necessary only to change the following registry key:

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\EditionID which in my case were CoreSingleVersion.

Cheers and thank you all.

Thank you so much @hessi9 and @mapk! I have consolidated this thread into a Gist


i don’t know if this is still an issue for you, but i just had the same problem.

using windows containers (@installation) instead of linux solved the problem for me

Hey guys,
I am having an issue with installing the Hyper-V components… the script is looping forever (it seems finished 100% but I need to close the powershell window to stop it).
I did try to install Docker with checking / unchecking boxes, got to install it, but there was an error at launch again.
Any ideas,


We have now released a version of Docker Desktop Edge that allows users of Windows Insider Preview (Win Home 19018 or higher) to use Docker Desktop with WSL 2.
If you are trying this out and have issues feel free to drop issues on the for-win Github Repo!


1 Like

I had followed @hessi9’s method to install docker. But now that it supports Windows 10 Home, without hyper v, I have been unable to deactivate hyper v, making virtualbox and intel haxm unusable.
I tried Disable-WindowsOptionalFeature -Online -FeatureName Microsoft-Hyper-V-All and it returns a success but there are hyperv network adapters and hyperv services running in task manager. When I open “Turn features on/off”, hyperv is unticked.

Any idea how to completely uninstall hyperv from windows 10 home?

Thanks a lot @hessi9 and @mapk . It works like a charm, follow the steps and working fine.

Do you try this?

thx! it work for me - docker 2.2.3

showing error please help to remove ?

1 Like

From May 2020 Docker is available on Win 10 Home. For that you will have to update for the last windows (Windows 10 Home. version 2004) and the new version of Linux Subsystem (WSL2). You can simply do it from your Control Panel.
After that, you can simply install Docker as described here:

No way, checked all requirements, updated everything - no way I can run this sh…